airPlay not working?


#1

Hi,

I have just started using popcorn time. Thanks to you all for this great app !

I can watch using the popcorn player, but airplaying to Apple TV is not working for me.
On the screen you see “streaming to Apple Tv”, but nothing is being streamed at all. Any idea?

Thanks!!


#2

Which Popcorntime version/build number?

Which Gen AppleTV are you using?


#3

Thanks for the reply

Popcorntime version/build number: 0.3.10-0

Apple TV: apple tv second generation.
model A1469
apple tv software: 7.2.2

Thanks!


#4

Hmm … 2nd Gen should work?

My old 3rd Gen worked - it was the 4th Gen (with its insistence on device verification) that broke things.

What OS are you using? You (obviously) can see your ATV device name in the PT “Watch Now” option list? PT says it’s streaming to the device (it carries on downloading)? But your ATV device is not activated? … would that be about it?

Is this happening with both movies and shows … everything? Are you using a VPN?


#5

Yes, I can see the “Apple TV” option in the “watch now” list
Then, it goes to the “connecting” screen
Next, PT says “streaming to Apple TV” and starts downloading (Downloaded %)…
…but nothing displays on the screen.

Airplay definitely works, as I can airplay the whole MAC screen no problem

My Mac is running Mojave (10.14.1)
No VPN
It happens in both movies and shows

thanks


#6

Unfortunately (for you), I’m no techie! :frowning:

Let me think about it? While you’re waiting … try this:

Download https://www.sodaplayer.com/ (third party app - useful for comparison testing). Copy the magnet link from PT (use one of the movies) and paste it into Soda Player - choose your ATV to playback … does that work?


#7

good idea.

I did it and it is working very well with soda, which proves there is an issue with PT I guess?

thanks a lot for your help. In fact, the soda player is a good fix until there is a solution (if the issue is confirmed and solved)

cheers


#8

As you’re using Mojave (I’m still on Sierra) I can’t make a direct comparison … but I can offer two options:

  1. Delete the Popcorntime.sh support files and reboot PT - you should get the T&C’s again? It may clear up a device “Handshake” issue?
    In Sierra (should be the same in Mojave) delete these PT support folders/file (manually):
    ~/Library/Application Support/Popcorn-Time (folder).
    ~/Library/Caches/Popcorn-Time (folder).
    ~/Library/Preferences/com.nw-builder.popcorn-time.plist (file).
    ~/Library/Saved Application State/com.nw-builder.popcorn-time.savedState (folder).
    for a new installation … or a clean reboot?

  2. Download one of the Ci (Dev) builds from Jenkins: https://ci.popcorntime.sh/view/All/ - they may have an improved implementation of Airplay? … or I can link you to my copy (there’s a problem with downloading at the mo … you’ll need a download manager: https://mac.eltima.com/download-manager.html to use Jenkins)?


#9

thank you. I will give it a go!

Have a nice weekend