Popcorn-Time won't start on Fedora 29 (Illegal instruction (core dumped))


#1

Hello everyone, i just downloaded Popcorn-Time from popcorntime.sh on Fedora 29, extracted the xz archive and when i try to run it, it will throw out bunch of error messages in console and will exit with Illegal instruction.

[13671:13671:0118/125058:ERROR:browser_main_loop.cc(238)] GTK theme error: Unable to locate theme engine in module_path: "murrine",
[13671:13671:0118/125058:ERROR:browser_main_loop.cc(238)] GTK theme error: Unable to locate theme engine in module_path: "murrine",
[13671:13671:0118/125058:ERROR:browser_main_loop.cc(238)] GTK theme error: Unable to locate theme engine in module_path: "murrine",
[13714:13714:0118/125058:ERROR:sandbox_linux.cc(345)] InitializeSandbox() called with multiple threads in process gpu-process. 
/home/mtodoric/Public/popcorn-time/Popcorn-Time[13716]: ../../third_party/node/src/node_crypto_bio.h:83:static node::NodeBIO *node::NodeBIO::FromBIO(BIO *): Assertion `(bio->ptr) != (nullptr)' failed.
Illegal instruction (core dumped)

Does anyone have any idea what should i do ?

OS: Fedora release 29 (Twenty Nine) x86_64
Host: HP 250 G6 Notebook PC
Kernel: 4.19.10-300.fc29.x86_64
Shell: bash 4.4.23
Resolution: 1920x1080, 1920x1080
DE: Cinnamon 4.0.7
WM: Mutter (Muffin)
WM Theme: Mint-Y-Dark (Mint-Y-Dark)
Theme: Mint-X-Blue [GTK2/3]
Icons: Mint-Y-Aqua [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-7200U (4) @ 3.100GHz
GPU: AMD ATI Radeon HD 8670A/8670M/8690M
GPU: Intel HD Graphics 620
Memory: 4036MiB / 7955MiB


#2

is your /tmp mounted as a tmpfs with noexec flag active ? remove this flag from /etc/systemd/system/tmp.mount or from your /etc/fstab line mounting /tmp.


#3

It’s not mounted with noexec.

[[email protected] ~]$ mount | grep '/tmp'
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
[[email protected] ~]$ cat /usr/lib/systemd/system/tmp.mount
#  SPDX-License-Identifier: LGPL-2.1+
#
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

[Unit]
Description=Temporary Directory (/tmp)
Documentation=man:hier(7)
Documentation=https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
ConditionPathIsSymbolicLink=!/tmp
DefaultDependencies=no
Conflicts=umount.target
Before=local-fs.target umount.target
After=swap.target

[Mount]
What=tmpfs
Where=/tmp
Type=tmpfs
Options=mode=1777,strictatime,nosuid,nodev

I don’t have /etc/systemd/system/tmp.mount, that file is located at /usr/lib/systemd/system/tmp.mount on my system.
Thanks for replying though. Any other ideas?

I should add that i had the same problem on Fedora 28 before installing 29.
I couldn’t fix it there either, i have though installed a much older version of popcorn time which worked. Don’t know where i found that old version, might not even be from a trusted source, but I’ve reinstalled OS since then so I’m good.