Update VLC libraries


#1

From @MrRory on Tue Nov 22 2016 19:56:23 GMT+0000 (UTC)

The VLC libraries are really outdated, they should be updated somewhere in the future.

Copied from original issue: https://github.com/popcorn-official/popcorn-android/issues/81


#2

From @vzamanillo on Tue Nov 22 2016 21:45:15 GMT+0000 (UTC)

I was thinking in removing the module code and include it as dependency but our code needs to be refactored due to hardware acceleration changes in the updated version.


#3

From @MrRory on Wed Nov 23 2016 10:16:16 GMT+0000 (UTC)

they don’t have an sdk like they have for iOS :confused:


#4

From @vzamanillo on Thu Dec 08 2016 01:51:52 GMT+0000 (UTC)

Maybe we should move to another alternatives like ExoPlayer


#5

From @team-pct on Thu Dec 08 2016 08:04:12 GMT+0000 (UTC)

Hmmm What about codecs? what is the issue with VLC we have a good contact with their team maybe they can help us if we have a specific problem


#6

From @MrRory on Fri Dec 16 2016 21:44:40 GMT+0000 (UTC)

There is no problem, ExoPlayer is just easier to implement and maintain

But contact with VLC?


#7

From @cooliobr on Fri Mar 10 2017 22:18:09 GMT+0000 (UTC)

@team-pct ExoPlayer use ffmpeg as audio renderer, then no problem with audio or sub.


#8

From @aldoborrero on Tue Apr 11 2017 08:33:01 GMT+0000 (UTC)

Work already done in #PR166. Updated to 2.0.6 (the most stable one).


#9

could you please add the option to use other players like MXplayer or VLC. Because these reprosuctores have more options and better subtitle support when using them from opensubtittles. In addition to better video options


#10

You can already use other video players by going into settings.